Tag Archives: weblink

Flashing an iDatalink Maestro RR using 64 Bit Windows 10

I recently purchased an iDatalink Maestro RR, and was surprised when I read the system requirements for the Weblink UpdaterWindows 7 now supported? Internet Explorer 7.0 or greater [Excluding 64 bit version]? 

Also, when I downloaded and ran the program, it told me it needed .NET framework 2.0.

I have a 64 Bit Windows 10 computer with .NET framework 4.x installed, but that’s not backward compatible with framework 2.0 apparently. Now what?

After some searching, I was able to flash the module on my computer. Here is how:

  1. You need to enable the .NET framework 2.0+ 3.5. It’s an option on Windows 10, you just need to enable it.
    1. In the search box type “Windows feature” to bring up the Windows Feature control.

      Turn Windows features on or off

      Turn Windows features on or off

    2. Check the .NET framework 3.5 (includes .NET 2.0 and 3.0).
      Windows Feature Control Panel

      Windows Feature Control Panel


    3. Windows will download the additional files it needs and request to reboot your computer.
  2. You also need a 32 bit version of Internet Explorer. Fortunately, that is also included on Windows 10.
    1. Open Internet Explorer.
    2. Go to Internet Options (upper right gear icon on the browser).

      Internet Options Menu

      Internet Options Menu

    3. Go to the Advanced tab and check “Enable Enhanced Protected Mode.”

      Enhanced Protection

      Enhanced Protection Mode

    4. On the Security tab, verify that Enable Protected Mode is checked. It should be. If not, check it.

      Enable Protected Mode

      Enable Protected Mode

  3. In the search box, type “user account control”.
  4. Select “Change User Account Control Settings”.
  5. Verify that the slider is not set to “Never notify.”

    User Account Control

    User Account Control

  6. You will need to reboot again.
  7. Install the Weblink Updater.
  8. Login to iDatalink.
  9. Plug your Maestro RR into a USB port.
  10. Try flashing your module. If you get a prompts at the bottom of the browser asking for permission to run the “adsService.service”, select yes.

If your computer doesn’t recognize the Maestro, try unplugging it from the computer, logging out of iDatalink, refreshing the iDatalink page, logging back in, and plugging the model back in.

It took me a couple of tries to get the module to flash completely. The first time the progress bar made it all the way to the end and then froze. The second time it worked, and the status of the module showed the correct firmware installed. I installed it in my car and it works great!

Good luck!